使用支持BLE 4.2规范的芯片进行实现应用系统设计

佚名 发表于 2020-02-12 14:37:37 收藏 已收藏
赞(0) •  评论(0

使用支持BLE 4.2规范的芯片进行实现应用系统设计

佚名 发表于 2020-02-12 14:37:37
+关注

蓝牙4.2规范提供了三项全新特性,使基于BLE的无线系统比之前的系统更快、更安全、更高效,包括数据长度扩展、低功耗安全连接以及链路层隐私保护。但是,想要完全支持这些特性,则需要升级链路层控制器和/或BLE主机协议栈,也就是说,应用设备的系统设计人员需要一块支持BLE 4.2规范的BLE芯片。

那么芯片厂商需要采取哪些改变措施,才能完全支持这些新特性呢?

与BLE4.1相比,链路层控制器有两个重大改变:

1. 支持251字节PDU:相比仅支持最大27字节PDU的BLE 4.1,BLE4.2链路层需要支持高达251字节的PDU,才能真正支持数据长度扩展特性。因此,链路层硬件设计通常需要改变。

2. 地址解析 – 由于地址在链路层进行解析,而解析表存储于链路层控制器中,因此链路层控制器也需要升级。这也会影响大多数在硬件或硬件和固件中实现链路层的设备。

任何在硬件中实现的链路层的BLE设备都需要升级到符合蓝牙4.2的芯片,而基于硬件和固件的链路层则很有可能需要对这两者进行更新。

对于主机控制器而言,最大的变化是:新增了安全加密功能、升级了配对过程和增加了数值比较关联模式。在大多数设备中,主机控制器是在CPU中实现的,因此只要引入新特性就需要更新固件。BLE协议栈较复杂,而且通常由BLE芯片厂商提供,但不同设备使用协议栈的方法取决于设备生产厂商。

至于应用,BLE广泛地使用于遥控器、可穿戴设备、消费设备等应用。这些市场发展迅速、产品生命周期较短,因此按时推出产品非常重要,否则将错过机会。为了保证BLE 4.2芯片系统的市场价值,建设相应的生态系统、加速产品设计变得至关重要。

以PSoC Creator 中的BLE组件为例。PSoC Creator是面向赛普拉斯的BLE SoC产品的集成开发环境,可让设计人员同时开发基于BLE的系统的硬件和软件。设计人员也可以先使用PSoC Creator 设计出硬件,包括布置ADC、运放、对比器、计时器等各类外设,然后将它们互连,并导出到Eclipse或Keil等常用IDE。PSoC Creator中的各类外设使用图标表示,可根据要求拖放组件。

设计人员可以使用PSoC Creator中的BLE组件在图形界面中向应用添加新特性。这些BLE组件包含了蓝牙4.2中定义的特性,可以非常方便地添加到系统;此外,BLE组件还简化了BLE协议栈的复杂性,帮助系统设计人员使用所有新特性,而且无需完成低层级的安装更新。

使用支持BLE 4.2规范的芯片进行实现应用系统设计

图1显示了BLE组件允许设计人员选择最大251字节的净荷。之后如果需要的话,还可使用应用编程接口(API)更改RX和TX净荷大小。

使用支持BLE 4.2规范的芯片进行实现应用系统设计

图2显示了BLE组件允许设计人员选择不同的参数和隐私选项。根据这些选择生成所需API,用于向应用添加安全特性。

但是,为了能够在整个通信系统中使用这些特性,两端通信设备都需要支持这些能力。某些设备目前可能不具备BLE 4.2能力。这种情况下,向后兼容性可以保证BLE 4.2的设备能与尚不支持BLE 4.2的设备配对。新款的智能手机通常如此——新款手机一般都支持最新的协议规范,但都必须要支持那些运行旧版协议栈的设备。但是,在BLE 4.2中,低功耗安全连接的严格配对特性一旦开启,设备就不能与BLE 4.1或更低版本的设备配对。BLE 4.2设备中需要增加一小段代码,以便在尝试配对前检查另一个设备是否支持低功耗安全连接严格配对特性。如果不支持,BLE 4.2设备应不使用低功耗安全连接严格配对方法进行配对。这样的话,如果其它设备升级到BLE 4.2之后,它就可以在无需任何修改的情况下使用低功耗安全连接严格配对方法。此外,新设备可能已经迁移至BLE 4.2,或与最新的BLE规范保持同步,以便利用最新规范的优势。

在产品设计周期的最初阶段,当系统设计人员面临选择BLE 4.1 (或更低版本)或BLE 4.2芯片时,其应当了解产品未来的升级需求,以便确保今后快速无缝转换到新版规范。为避免今后重新流片来支持蓝牙4.2特性,设计系统时应使用符合蓝牙4.2的BLE芯片。这样,硬件只需研发一次,从而确保降低成本,并且降低固件开发成本和测试成本。

大多数厂商提供符合BLE 4.2标准的器件,并且与前几代器件引脚兼容。因为厂商通常都希望保持高级API不变,因此在很多情况下为旧版芯片编写的应用固件同样适用于BLE 4.2。因此,即使在生产阶段,仍然可以使用支持最新版BLE规范的芯片升级硬件,并且没有延误。固件可以稍后升级来支持新特性。如果安装了空中引导加载程序,那么产品发布后也可以进行固件升级。

总的来说,使用符合最新版协议的组件设计系统时,生态系统的状态就非常重要;特别是产品周期较短、需要通过支持新特性来获得差异化竞争力时,生态系统变得更加关键。对于那些需要支持未来升级、以便让最终应用在无需更改硬件的情况下支持最新版BLE规范的系统,应考虑使用符合BLE 4.2规范的芯片。易用、基于GUI的开发工具可帮助设计人员轻松、经济高效地开发符合蓝牙4.2的无线系统。

责任编辑:gt

声明:本文由入驻电子说专栏的作者撰写或者网上转载,观点仅代表作者本人,不代表电子发烧友网立场。如有侵权或者其他问题,请联系举报。侵权投诉

收藏

相关话题

评论(0)

加载更多评论

分享到

QQ空间 QQ好友 微博
取消