路由器与三层交换机怎么实现端口聚合

网络整理 12-05 0评

  路由器与三层交换机怎么实现端口聚合

  与路由器间的端口聚合是三层端口的困绑,要求交换机的逻辑通道工作在三层模式下,使用no switchport 关闭二层通道。并设置IP地址。

  switchA#conf t

  switchA(config)#int port-channel 5   ;进入逻辑通道5

  switchA(config-if)#no switchport   ;定义为三层接口

  switchA(config-if)#ip address 10.65.1.1 255.255.0.0 ;设置通道IP地址

  switchA(config-if)#exit switchA(config)#int range f0/1 -2 ;进入物理接口

  switchA(config-if-range)#no ip address ;去掉物理接口IP

  switchA(config-if-range)#channel-group 5 mode on   ;设通道5手动方式

  switchA(config-if-range)#no shutdown

  switchA(config-if-range)#exit

  switchA(config-if)#end

  switchA#

  router#conf t

  router(config)#int port-channel 5 ;进入逻辑通道5

  router(config-if)#ip address 10.65.1.2 255.255.0.0 ;设通道IP地址

  router(config-if)#int f0/0 ;进入物理端口

  router(config-if)#no ip address ;去掉端口IP地址

  router(config-if)#no shutdown ;激活物理端口

  router(config-if)#channel-group 5 ;添加到通道5

  router(config-if)#int f0/1

  router(config-if)#no ip address

  router(config-if)#no shutdown

  router(config-if)#channel-group 5

  router(config-if)#end router

  交换机的端口聚合配置

  技术原理

  端口聚合使用的是EtherChannel特性,在交换机到交换机之间提供冗余的高速的连接方式。将两个设备之间多条FastEthernet或GigabitEthernet物理链路捆在一起组成一条设备间逻辑链路,从而增强带宽,提供冗余。

  两台交换机到计算机的速率都是100M,SW1和SW2之间虽有两条100M的物理通道相连,可由于生成树的原因,只有100M可用,交换机之间的链路很容易形成瓶颈,使用端口聚合技术,把两个100M链路聚合成一个200M的逻辑链路,当一条链路出现故障,另一条链路会继续工作。

  一台S2000系列以太网交换机只能有1个汇聚组,1个汇聚组最多可以有4个端口。组内的端口号必须连续,但对起始端口无特殊要求。

  在一个端口汇聚组中,端口号最小的作为主端口,其他的作为成员端口。同一个汇聚组中成员端口的链路类型与主端口的链路类型保持一致,即如果主端口为Trunk端口,则成员端口也为Trunk端口;如主端口的链路类型改为Access端口,则成员端口的链路类型也变为Access端口。

  所有参加聚合的端口都必须工作在全双工模式下,且工作速率相同才能进行聚合。并且聚合功能需要在链路两端同时配置方能生效。

  端口聚合主要应用的场合:

  交换机与交换机之间的连接:汇聚层交换机到核心层交换机或核心层交换机之间。

  交换机与服务器之间的连接:集群服务器采用多网卡与交换机连接提供集中访问。

  交换机与路由器之间的连接:交换机和路由器采用端口聚合解决广域网和局域网连接瓶颈。

  服务器和路由器之间的连接:集群服务器采用多网卡与路由器连接提供集中访问

  视图:全局配置模式下

  命令:

  interface range interface_name1 to interface_name2

  Switchport mode trunk

  channel-group 1 mode on 加入链路组1并开启

  参数:

  interface_name1:聚合起始端口

  interface_name2:聚合结束端口。

  trunk表示端口可以转发所有Vlan包

  将2个或多个物理端口组合在一起成为一条逻辑的路径,即链路channel-group,同时也形成了一个逻辑端口port-channel(一个整体)

  switchport mode access是直接接主机的,所属VLAN中的接口,都是access

  switchport mode trunk trunk mode 的接口可以同时传输多个VLAN信息的。

  trunk mode 常用在两个SWITCHand ROUTER , switch and switch 特权模式下

  Switch#show etherchannel summary:显示相关汇聚端口组的信息;

  实验设备

路由器与三层交换机怎么实现端口聚合

  Switch_2960 2台;PC 4台;直连线

  Switch0:具体操作

  Switch》

  Switch#config t

  Switch(config)#interface range f0/1-2

  Switch(config-if-range)#Switchport mode trunk //设置端口模式为trunk

  Switch(config-if-range)#channel-group 1 mode on //加入链路组1并开启

  Switch(config-if-range)#exit

  Switch(config)#port-channel load-balance dst-ip //按照目标主机IP地址数据分发来实现负载平衡

  Switch(config)#exit

  Switch#show etherchannel summary

  Switch1:具体操作Switch》

  Switch#config t

  Switch(config)#interface range f0/1-2

  Switch(config-if-range)#Switchport mode trunk //设置端口模式为trunk

  Switch(config-if-range)#channel-group 1 mode on //加入链路组1并开启

  Switch(config-if-range)#exit Switch(config)#port-channel load-balance dst-ip //按照目标主机IP地址数据分发来实现以太网通道组负载平衡

  Switch(config)#exit

  Switch#show etherchannel summary //显示以太网通道组的情况

  PC0设置

  192.168.1.2

  255.255.255.0

  PC1设置

  192.168.1.3

  255.255.255.0

  PC0 ping PC1 Reply

  PC1 ping PC0 Reply

编辑推荐
相关文章
热门推荐

0个回复

我要评论

热门标签