思科路由器配置基础_7个方面详解cisco路由器配置

陈翠 发表于 2018-05-14 09:32:00 收藏 已收藏
赞(0) •  评论(0

思科路由器配置基础_7个方面详解cisco路由器配置

陈翠 发表于 2018-05-14 09:32:00

  大家一定对Cisco路由器并不陌生,作为第一个入行的国际化企业而言,它的产品众所周知,但也正因为如此让大家对于一些有关它的配置有所困惑,本文主要介绍的是思科路由器配置基础,分别从所处状态各类、配置IP寻址、配置静态路由、配置动态路由(RIP)、配置DHCP、配置NAT等方面详细介绍思科路由器配置基础,具体的跟随小编一起来了解一下。

  一、所处状态各类

  router》

  用户处于用户命令状态,可以查看网络和主机

  router#

  用户处于特权模式,可以查看状态,还可以看到和更改路由器的设置内容

  router(config)#

  全局配置状态,可以设置路由的全局参数

  router(config-if)#;router(config-line)#;router(config-router)#

  处于局部配置状态,可以设置路由的局部参数

  思科路由器配置基础_7个方面详解cisco路由器配置

  二、配置IP寻址

  1、 IP地址分类

  IP地址分为网络地址和主机地址二个部分,A类地址前8位为网络地址,后24位为主机地址,B类地址16位为网络地址,后16位为主机地址,C类地址前24位为网络地址,后8位为主机地址,网络地址范围如下表所示:

  种类网络地址范围

  思科路由器配置基础_7个方面详解cisco路由器配置

  2、分配接口IP地址

  思科路由器配置基础_7个方面详解cisco路由器配置

  3. 使用可变长的子网掩码

  通过使用可变长的子网掩码可以让位于不同接口的同一网络编号的网络使用不同的掩码,这样可以节省IP地址,充分利用有效的IP地址空间。

  如下图所示:

  思科路由器配置基础_7个方面详解cisco路由器配置

  Router1和Router2的E0端口均使用了C类地址192.1.0.0作为网络地址,Router1的E0的网络地址为192.1.0.128,掩码为255.255.255.192, Router2的E0的网络地址为192.1.0.64,掩码为255.255.255.192,这样就将一个C类网络地址分配给了二个网,既划分了二个子网,起到了节约地址的作用。

  4. 使用网络地址翻译(NAT)

  NAT(Network Address Translation)起到将内部私有地址翻译成外部合法的全局地址的功能,它使得不具有合法IP地址的用户可以通过NAT访问到外部Internet.

  当建立内部网的时候,建议使用以下地址组用于主机,这些地址是由Network Working Group(RFC 1918)保留用于私有网络地址分配的。

  1) Class A:10.1.1.1 to 10.254.254.254

  2)Class B:172.16.1.1 to 172.31.254.254

  3)Class C:192.168.1.1 to 192.168.254.254

  命令描述如下:

  思科路由器配置基础_7个方面详解cisco路由器配置

  如下图所示,

  思科路由器配置基础_7个方面详解cisco路由器配置

  路由器的Ethernet 0端口为inside端口,即此端口连接内部网络,并且此端口所连接的网络应该被翻译,Serial 0端口为outside端口,其拥有合法IP地址(由NIC或服务提供商所分配的合法的IP地址),来自网络10.1.1.0/24的主机将从IP地址池c2501中选择一个地址作为自己的合法地址,经由Serial 0口访问Internet。命令ip nat inside source list 2 pool c2501 overload中的参数overload,将允许多个内部地址使用相同的全局地址(一个合法IP地址,它是由NIC或服务提供商所分配的地址)。命令ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192定义了全局地址的范围。

  设置如下:

  ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192

  interface Ethernet 0

  ip address 10.1.1.1 255.255.255.0

  ip nat inside

  !

  interface Serial 0

  ip address 202.200.10.5 255.255.255.252

  ip nat outside

  !

  ip route 0.0.0.0 0.0.0.0 Serial 0

  access-list 2 permit 10.0.0.0 0.0.0.255

  ! Dynamic NAT

  !

  ip nat inside source list 2 pool c2501 overload

  line console 0

  exec-timeout 0 0

  !

  line vty 0 4

  end

  三、配置静态路由

  通过配置静态路由,用户可以人为地指定对某一网络访问时所要经过的路径,在网络结构比较简单,且一般到达某一网络所经过的路径唯一的情况下采用静态路由。

  思科路由器配置基础_7个方面详解cisco路由器配置

  思科路由器配置基础_7个方面详解cisco路由器配置

  以下在Router1上设置了访问192.1.0.64/26这个网下一跳地址为192.200.10.6,即当有目的地址属于192.1.0.64/26的网络范围的数据报,应将其路由到地址为192.200.10.6的相邻路由器。在Router3上设置了访问192.1.0.128/26及192.200.10.4/30这二个网下一跳地址为192.1.0.65。由于在Router1上端口Serial 0地址为192.200.10.5,192.200.10.4/30这个网属于直连的网,已经存在访问192.200.10.4/30的路径,所以不需要在Router1上添加静态路由。

  Router1:

  ip route 192.1.0.64 255.255.255.192 192.200.10.6

  Router3:

  ip route 192.1.0.128 255.255.255.192 192.1.0.65

  ip route 192.200.10.4 255.255.255.252 192.1.0.65

  同时由于路由器Router3除了与路由器Router2相连外,不再与其他路由器相连,所以也可以为它赋予一条默认路由以代替以上的二条静态路由,

  ip route 0.0.0.0 0.0.0.0 192.1.0.65

  即只要没有在路由表里找到去特定目的地址的路径,则数据均被路由到地址为192.1.0.65的相邻路由器。

  四、配置动态路由(RIP)

  命令

  en

  config t //全局模式

  no route rip //禁止rip协议

  route rip

  network 192.168.1.0 //network参数为路由的两个端口对应的网络地址

  network 192.168.10.0

  exit

  end

  disable

思科路由器配置基础_7个方面详解cisco路由器配置

  五、配置DHCP

  命令

  en

  config t //全局模式

  ip dhcp excluded-address 192.168.1.1 //需要排除的ip地址

  ip dhcp pool gr-dhcp-pool //ip地址池名

  default-server 192.168.1.1 //指定dhcp服务器

  network 192.168.1.0 255.255.255.0 //配置网络

  dns-server 61.177.7.1 //配置dns服务器

  exit

  end

  disable

  可以通过 ip helper-address指定 DHCP中继代理

  interface FastEthernet0/1

  ip address 192.168.1.1 255.255.255.0

  ip helper-address 192.168.10.2 //配置DHCP中继代理,DHCP

思科路由器配置基础_7个方面详解cisco路由器配置

  六、配置NAT

  命令

  en

  config t //全局模式

  interface f0/0

  ip address 192.168.1.1 255.255.255.0

  ip nat inside //内部端口

  no shu

  exit

  interface f0/1

  ip address 192.168.10.1 255.255.255.0

  ip nat outside //外部端口

  no shu

  exit

  access-list 1 permit any //设置一个可访问列表

  ip nat pool gr-nat-pool 192.168.10.3 192.168.10.254 netmask 255.255.255.0 //设置分配池

  ip nat inside resource list 1 pool gr-nat-pool overload

  show ip nat traslations

  clear ip nat traslation *

  七、其它

  sh running-config //显示当前运行配置

  sh startup-config //显示开机配置

  sh ip route //显示路由

  sh nat traslations //显示nat当前情况

收藏

相关话题
文章来源栏目
+关注

评论(0)

加载更多评论

参与评论

相关文章

分享到

QQ空间 QQ好友 微博
取消